Preupgradecheck errors -Part -2


The following feature(s) are referenced by the content, but they are not installed on the web server

 Name = Unknown, Feature id = GUID, Reference count = 1, Scope = Web, Status = Missing             
 Name = Unknown, Feature id = GUID, Reference count = 2, Scope = Web, Status = Missing             
 Name = Unknown, Feature id = GUID, Reference count = 1, Scope = Web, Status = Missing            

Steps to fix the errors

    1st Method

1. Download Feature Admin tool from http://featureadmin.codeplex.com/
2. Run the exe and click “Find faulty features” in the farm which will detect the faulty features now remove the faulty feature by using “Remove Feature from farm” option.

    2nd method

1.From the PreUpgradeCheck report note the feature GUID
2. Run following query on DBs (Content db and central admin db) to verify that the feature exists on Central Admin DB

SELECT * FROM FEATURES WITH(NOLOCK) WHERE FEATUREID=’GUID’

This query will display WebId , SiteId and other details about the feature.
3. Run

STSADM -o deactivatefeature -id GUID -force            

4. Download the utility WssRemoveFeatureFromSite from http://code.msdn.microsoft.com/WssRemoveFeatureFrom
5. Go to command prompt and point to WSSRemoveFeatureSite directory and type:
WssRemoveFeatureFromSite -scope (site|sitecollection) -url -featureid -force

Advertisements

About amritatalreja
I am working as a SharePoint Consultant in HCL America INC, Cary,NC.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: